fs.existsSyncが非推奨ではなくなっていた

node.jsのドキュメントを読んでいた時にfs.existsSync()が非推奨ではなくなっていたことにふと気がついた。

調べてみるとver.6.xから非推奨ではなくなっている。

バージョン 記述
0.10.x 特になし
0.12.x 非推奨になります
4.x 非推奨
5.x 非推奨
6.x 非推奨ではありません
7.x 非推奨ではありません

調べてみると、issues/1592commit/7b5ffa46fe4d2868c1662694da06eb55ec744bdeで非推奨が取り消されているのを確認できた。

非同期のfs.exists()は変わらず非推奨になっている。